Kusprayitna Blogs

Hidup untuk berbagi ilmu :: IT Linux Windows Database Oracle PHP OpenSource

Archive for August 13th, 2008

Install Flash Plugins di Ubuntu

Posted by kusprayitna on 13th August 2008

Ada yang kelewatan dalam memakai ubuntu hardy heron, saat browsing website yang memakai flash ternyata flashnya belum terinstall.

Di Firefox ketika flash dibutuhkan akan memunculkan dialog install missing plugins, dimana ditawarkan ada tiga buah, yaitu dari Adobe dan duanya tadi lupa . Tapi dari tiga-tiganya jika diinstall langsung error semua, antara lain muncul pesan bahwa file tidak ditemukan (lupa tidak di copy).

Jadi instalasi harus dilakukan secara manual.

Download file installer dari Adobe, http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-9.0.124.0-release.i386.rpm

Dari instruksi instalasinya jalankan perintah : rpm -Uvh <nama file rpm> di terminal

Saat dijalankan, ada pesan error tentang dependency :

error: Failed dependencies:
/bin/bash is needed by flash-plugin-9.0.124.0-release.i386
/bin/sh is needed by flash-plugin-9.0.124.0-release.i386
libX11.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libXext.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libXt.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libc.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libc.so.6(GCC_3.0) is needed by flash-plugin-9.0.124.0-release.i386
libc.so.6(GLIBC_2.0) is needed by flash-plugin-9.0.124.0-release.i386
libc.so.6(GLIBC_2.1) is needed by flash-plugin-9.0.124.0-release.i386
libc.so.6(GLIBC_2.1.3) is needed by flash-plugin-9.0.124.0-release.i386
libc.so.6(GLIBC_2.2) is needed by flash-plugin-9.0.124.0-release.i386
libc.so.6(GLIBC_2.3) is needed by flash-plugin-9.0.124.0-release.i386
libdl.so.2 is needed by flash-plugin-9.0.124.0-release.i386
libdl.so.2(GLIBC_2.0) is needed by flash-plugin-9.0.124.0-release.i386
libdl.so.2(GLIBC_2.1) is needed by flash-plugin-9.0.124.0-release.i386
libfontconfig.so.1 is needed by flash-plugin-9.0.124.0-release.i386
libfreetype.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libglib-2.0.so.0 is needed by flash-plugin-9.0.124.0-release.i386
libgobject-2.0.so.0 is needed by flash-plugin-9.0.124.0-release.i386
libgtk-x11-2.0.so.0 is needed by flash-plugin-9.0.124.0-release.i386
libm.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libm.so.6(GLIBC_2.0) is needed by flash-plugin-9.0.124.0-release.i386
libpthread.so.0 is needed by flash-plugin-9.0.124.0-release.i386
libpthread.so.0(GLIBC_2.0) is needed by flash-plugin-9.0.124.0-release.i386
libpthread.so.0(GLIBC_2.1) is needed by flash-plugin-9.0.124.0-release.i386
libpthread.so.0(GLIBC_2.2) is needed by flash-plugin-9.0.124.0-release.i386
libpthread.so.0(GLIBC_2.2.3) is needed by flash-plugin-9.0.124.0-release.i386
libpthread.so.0(GLIBC_2.3.2) is needed by flash-plugin-9.0.124.0-release.i386

Untuk mengatasinya bisa gunakan perintah berikut:

rpm -Uvh <nama file fpm> --nodeps

kemudian restart firefox anda, horeee flash sudah bisa terlihat

Posted in Linux, Ubuntu | 1 Comment »

MUI Akhirnya Keluarkan Fatwa MEROKOK Hukumnya HARAM

Posted by kusprayitna on 13th August 2008

Akhir-akhir ini merak keluar desakan untuk MUI mengeluarkan Fatwa Merokok itu HARAM.

Mengapa merokok haram? selama ini merokok hukumnya adalah makruh lebih condong ke haram, tetapi tidak haram.

Kemarin pagi , Selasa 12 Agustus 2008 memalui berita TV dari dewan syariah MUI menyampaikan fatwa terbarunya tentang merokok, yaitu :

"Merokok Hukumnya adalah HARAM bagi anak-anak dibawah usia 17 Tahun"

Ada beberapa alasan yang melatar belakanginya, antara lain :

1. Selama ini hukum merokok makruh cenderung atau lebih dekat ke haram

2. Larangan pemerintah melalui PP/Perda yang sudah ada dan berlaku sampai sekarang tidak banyak yang mengindahkannya atau banyak di langgar. Misalnya larangan merokok di taman atau di ruang tertentu yang dikeluarkan pemda, masih juga ada yang merokok di ruang tersebut. (di UII masih adakah merokok di tempat umum?)

3. Perokok khususnya anak-anak tidak ada manfaatnya sedikitpun, dll

Dari fatwa ini menurut pendapat saya akan membawa dampak yang luas, kenapa?

1. Barang yang sedikitnya haram berarti banyaknya juga haram hukumnya, hati-hatilah orang tua yang merokok, janganlah anda merokok, apalagi diketahui oleh anak-anak, mereka mencontoh anda!

2. Perokok anak-anak di lingkungan industri rokok, mereka itu usia 2 tau 5 tahun merokok merupakan hal yang biasa.

3. Pekerjaan terkait yang haram, maka hukumnya menjadi haram. Para pekerja industri rokok, penjual rokok, dll ... berhati-hatilah. Rejeki anda dari rokok menentukan nasih hidup anda di dunia dan akhirat. Anda konsumsi makanan haram dalam tubuh, maka barang tersebut akan berada dalam tubuh anda selama 40 hari dan ibadah anda selama itu tidak diterima oleh Allah. Subhanallah.

4. Ayo' hidup sehat, karena merokok dapat menyebabkan kanker, stroke dan gangguan janin dan kehamilan.

Posted in Others | 103 Comments »